Actualización PODDLE módulo de Paypal para Prestashop

Prestashop y Paypal han sacado una actualización de su módulo de pago, su actualización es obligatoría para todas las tiendas Prestashop a partir del 3 de diciembre de 2014, ya que van a cambiar el protocolo de SSL V3 a TLS.

20 Nov 2014

Prestashop y Paypal han sacado una actualización de su módulo de pago, su actualización es obligatoría para todas las tiendas Prestashop a partir del 3 de diciembre de 2014, ya que van a cambiar el protocolo de SSL V3 a TLS.

La actualización se debe a una vulnerabilidad del protocolo SSL mediante POODLE, es el protocolo que se estaba utilizando para proteger los datos de los clientes para que debido a su antigüedad, unos 15 años, han conseguido tener acceso a estos datos, ahora, Paypal ha optado por utilizar el protocolo TLS que es más actual y seguro, podéis ver el comunicado oficial de Prestashop aquí

El pasado mes ya pudimos comprobar en nuestras carnes como en algunas tiendas dejaban de funcionar todos los pagos de Paypal, porque Paypal se encontraba realizando pruebas con el nuevo entorno, y en hora punta del día… pasadas unas horas todo volvió a la normalidad y se nos indicó que estaban probando el nuevo protocolo y que debíamos proceder a realizar los cambios.

Si estás usando Paypal en tu tienda Prestashop, es necesario que actualices el módulo a la versión 3.8.0 disponible desde el martes pasado, lo puedes descargar de la Addons Oficial o pulsando en el backoffice de tu tienda. Supongo que tendrás tu duda de si funciona o no, en ese caso, si lo quieres probar antes de que llegue la temida fecha puedes probarlo usando el entorno de pruebas de Paypal donde ya está activo el protocolo TLS.

Si te aparece un error similar al indicado abajo, es que algo está mal en tu módulo o servidor, tendrás que volver a revisar que problema existe:

* Unknown SSL protocol error in connection to api-3t.sandbox.paypal.com:-9824

También recordaros que nuestro módulo de paypal con comisión es totalmente compatible con el nuevo protocolo, va a funcionar mediante el protocolo SSL y en cuanto lo activen funcionará con el protocolo TLS. Recordar que solo existe esa compatibilidad  con la versión 1.6 del módulo, las otras versiones que tenemos de paypal para Prestashop no funcionan con el protocolo TLS.

Una vez actualizado cualquier de los dos módulos, el oficial o el que tenemos con recargo, es necesario o recomendable regenerar la API en Paypal, más que nada por tema de seguridad.

Deja una respuesta